Nochmal Linux und NAS: ungewünschten Prozess beenden oder nicht starten

PC allgemein
Antworten
Benutzeravatar
OELFUSS
Site Admin
Site Admin
Beiträge: 2903
Registriert: Do 3. Okt 2002, 23:00
Wohnort: Oer-Erkenschwick
Kontaktdaten:

Nochmal Linux und NAS: ungewünschten Prozess beenden oder nicht starten

Beitrag von OELFUSS » Di 24. Jan 2017, 10:35

So, noch ein weiteres Problem bezüglich des NAS...

Die Netzwerkfestplatte läuft unter Linux. Eigentlich wäre alles schön - wenn sie sich nicht mit großer Regelmäßigkeit von der Außenwelt abschotten würde. Die Platte ist dann weder als Netzwerklaufwerk, noch über ihre Web-Bedienoberfläche, noch über FTP zu erreichen. Auch Telnet ist dann tot.

Ein PING-Echo kommt aber noch zurück! Und intern scheint sie auch noch einwandfrei zu funktionieren. So kann man z.B. einen USB-Stick anstecken und per Tastendruck die Kopieraktion auf die Platte auslösen. Das klappt!

Sucht man im Netz, findet man heraus, dass quasi alle Benutzer dieser Netzwerkplatte früher oder später dieses Problem haben. (Es ist eine Medion MD86587). Als Ursache wird manchmal der Virenscanner - meist Avast - ausgemacht. Den habe ich tatsächlich im Einsatz, aber die Änderungen in dessen Config haben keinen Erfolg gebracht. Manchmal wurde auch die Fritzbox als Übeltäter vermutet. Da glaube ich eher nicht dran.

Ich glaube im Moment eher, dass der Medienserver Twonky etwas damit zu tun hat. Den kann man aber nicht abschalten. Aber ich habe ja Shell-Zugriff. Also kann ich vielleicht Prozesse beenden oder ein Script ändern, in dem Twonky gestartet wird. So weit bin ich aber noch nicht, weil ich nur rudimentäre Linux-Kenntnisse habe, die zudem auch noch eingerostet sind.

Auf jeden Fall kann man z.B. ps aufrufen und erhält dann schätzungsweise 50 Prozesse aufgelistet. Darunter auch zwei, wenn ich nichts übersehen habe, die etwas mit Twonky zu tun haben. Vermutlich kann ich mit exit oder kill die Prozesse beenden. Habe das noch nicht versucht, weil aktuell die Platte durchgehalten hat. Vielleicht war ein anderer Weg auch erfolgreich, muss sich noch erweisen.

Nochmal zurück zu den Prozessen: es gibt auch noch top, und damit werden nur noch ungefähr die Hälfte der Prozesse angezeigt. Die beiden Twonky-Prozesse sind aber auch wieder dabei. Ich habe mich noch nicht weiter eingelesen, was das alles zu bedeuten hat. Jedenfalls ist das so natürlich doof. Das NAS soll gefälligst durchgehend erreichbar sein. Aktuell schalte ich es über eine intelligente Steckdose im Fehlerfall aus und wieder ein...

Benutzeravatar
OELFUSS
Site Admin
Site Admin
Beiträge: 2903
Registriert: Do 3. Okt 2002, 23:00
Wohnort: Oer-Erkenschwick
Kontaktdaten:

Re: Nochmal Linux und NAS: ungewünschten Prozess beenden oder nicht starten

Beitrag von OELFUSS » Di 24. Jan 2017, 10:41

Noch kurz meine Gedanken zu Virenscanner und Roter im Zusammenhang mit dem "Verschwinden" des NAS:

Wäre es der Virenscanner, so müsste ja irgendeine Anfrage von ihm über das Netz kommen, die die Platte nicht verknusen kann und über die sie mit irgendwelchen Prozessen crasht. Ist eher unwahrscheinlich, aber wohl auch nicht ausgeschlossen. Bedeutet dann, dass sämtliche Rechner, die solch einen Virenscanner in meinem Netz nutzen, umgerüstet oder umkonfiguriert werden müssen.

Es sei denn, der Router könnte den Schaden abwenden. Zumindest für die Fritzbox 7490 habe ich aber gelesen, dass die LAN-Pakete immer ohne Filterung durchgehen. Nur für's WAN, also Internet, wird gefiltert. Wenn ich das nicht falsch verstanden habe. Das NAS hängt allerdings hinter einer 7270-Box. Da könnte es anders sein. Was ich aber auch nicht glaube...

Wenn der Router selbst Schuld am Verschwinden des NAS trüge, müsste man ihn wahrscheinlich in seinem Verhalten einschränken. Wenn es der Virenscanner ist, und der Router dazwischen was ausrichten kann, müsste man seine Filter erweitern...

Hmmmm...

Benutzeravatar
OELFUSS
Site Admin
Site Admin
Beiträge: 2903
Registriert: Do 3. Okt 2002, 23:00
Wohnort: Oer-Erkenschwick
Kontaktdaten:

Re: Nochmal Linux und NAS: ungewünschten Prozess beenden oder nicht starten

Beitrag von OELFUSS » Di 24. Jan 2017, 12:37

OELFUSS hat geschrieben: Ich glaube im Moment eher, dass der Medienserver Twonky etwas damit zu tun hat. [...] Also kann ich vielleicht Prozesse beenden oder ein Script ändern, in dem Twonky gestartet wird. [...]

Vermutlich kann ich mit exit oder kill die Prozesse beenden. Habe das noch nicht versucht, weil aktuell die Platte durchgehalten hat.
So. Komisch. Über Nacht hat es den NAS-Server nicht weggerissen. Wohl aber vorhin wieder. Hmm... Also nächster Versuch.

exit gefolgt von der pid geht nicht. Also kill -sigterm pid für die beiden Prozesse probiert: das geht. Prozesse sind weg. Ob es dabei bleibt oder die von irgend etwas wieder gestartet werden, muss ich mal sehen. Und ob es mein Problem löst, auch...

Auf jeden Fall ist unter Port 9001 jetzt der Twonky-Server nicht mehr erreichbar. Die Weboberfläche auf Port 80 tut es noch.

Antworten